3PM - We are experiencing delays in processing Bills and Timesheets – Incident details
Report an issue
Get updates
Email
SMS
Webhook
Report an issue
Get updates
Dark mode
All systems operational
We are experiencing delays in processing Bills and Timesheets
Resolved
Operational
Started 4 months ago
Lasted about 19 hours
Affected
Web Portal
Operational from 2:24 AM to 9:49 PM
Document Extractor
Operational from 2:24 AM to 9:49 PM
Updates
Resolved
06 Dec 2024 at 9:49 PM
Resolved
06 Dec 2024 at 9:49 PM
This incident has been resolved.
Investigating
06 Dec 2024 at 2:24 AM
Investigating
06 Dec 2024 at 2:24 AM
We are currently investigating this incident.