3PM - We are experiencing a major portal outage – Incident details

All systems operational

We are experiencing a major portal outage

Resolved
Major outage
Started almost 2 years agoLasted about 2 hours

Affected

Web Portal

Major outage from 2:16 AM to 4:37 AM

Mobile App

Major outage from 2:16 AM to 4:37 AM

Form Builder

Degraded performance from 2:16 AM to 4:37 AM

Updates
  • Resolved
    UTC
    Resolved

    The Portal Issue has been resolved and the all the services have resumed. We are currently monitoring it and will update you when everything is back to normal

  • Identified
    UTC
    Identified

    We have Identified the issue and are working on it. You will not be able to submit some information until it is resolved. We have a timeline that it will be resovled by 4PM today.